Lesson 13: Tracing
Previous Topic  Next Topic 

Lesson 13: How to Trace Scanned Images


Lets say that youve drawn an appliqué flower on paper. In this lesson, well learn how to trace

the flower so that you can use it in Perfect Quilt.


Why cant Perfect Quilt just automatically convert scanned images? Why do I have to trace

over them?


The explanation is a bit technical, but here it goes. There are two ways for a computer to make a visual image. One is called Bitmap and the other is Vector. What are they?


Bitmap images are made of thousands of tiny dots called pixels. When you see the pixels at a distance, they form an imagejust like a newspaper photograph. On the computer, photographs (like you take with a digital camera) are bitmap images. Common bitmap file formats are .bmp (windows bitmap) and .jpg. .Jpgs are used in websites. The fabrics in Perfect Quilt are bitmap images. When you scan an image, even a line drawing, it is a bitmap image.


Vector images are line drawings that are mathematically calculated. Because all the lines are  athematically generated, you get very smooth and accurate lines. Vector-created drawings can be easily and accurately resized. Perfect Quilt uses vectors to create patches, blocks and quilts.



The reason that Perfect Quilt cant just automatically convert a scanned image is that it would have to somehow convert the scanned bitmap image into a vector drawing. This requires computing power far beyond Perfect Quilts capabilities. Therefore, you have to manually trace over a scanned image with Perfect Quilts vector drawing tools. But dont despair! Its not hard and with a little practice, youll soon be an expert tracer.


About Copyrights

Before we begin tracing lesson, we need to remind you that it is illegal to copy a copyrighted image from a magazine, book, class-handout or any other copyrighted image. Most books and magazines will allow you to copy an image for your own personal use, but you should consult the book or author if you have any doubts.

Please remember that your are responsible for obeying the copyright laws and that anything that you create with Perfect Quilt is your own creation and responsibility . That means that if you create an original design with Perfect Quilt, it is yours to copyright (Perfect Quilt does not have any copyright claim to the design.) On the other hand, if you copy somebody elses design with Perfect Quilt, then you may be liable for any damages.


Scanning Images to Trace

Obviously, the first step to tracing images is to have something to trace. In this lesson, well open a sample image from our tracing library. Later, youll want to scan your own images. To learn how to scan, please refer to Lesson 10: Scanning Wizard. Instead of choosing fabric, choose tracing background as the type of image to scan.


Preparing to Trace

First, we need to place the scanned image on the Design Wall so that you can trace over it.

Heres how:

1. Click on the New File Icon on the Ribbon bar.

2. Click on the Block Wizard Icon on the Ribbon bar.

3. Click on the Tracing Tab.

4. Click on Oak Leaf in the drop-down box.

5. Quilt-pro will show you a preview the image.


You are now ready to place the Oak Leaf on the Design Wall for tracing.




Where do you Want to Place the Image?

To place the Oak Leaf on the Design Wall, choose the horizontal and vertical offset. If you select 0 x 0, this means that the image will appear in the upper left corner of the Design Wall. If you select 3" x 3", this means that the image will appear 3" to the right and 3" down.


Hint: Scanned images for tracing are NOT regular Perfect Quilt patches. This means that you cant just select them and move them around. The scanned image for tracing will appear behind the drawing grid. Also, the scan will not be part of any Perfect Quilt file you save.


How Large do you Want the Tracing Image to be?

Perfect Quilt will tell you how large your image is. You can make the image as large or small as you want. Just adjust the horizontal and vertical size. To keep the image in proportion, click on the keep proportion box.


Placing the Tracing Image on the Design Wall

1. To place the image on the Design Wall, click the enabled box and the click on the OK Button.

2. Now you are ready to trace the image.

3. Hint: to get in close on your image, use the Zoom In Tool .

4. To delete the scanned image from the Design Wall, click the enabled box again so that the checkbox is empty.



Tracing the Oak Leaf with the Freehand Curve

After all this preparation, we are finally ready to trace the Oak Leaf. We will use the Freehand Curve Tool to trace. For curves and appliqué shapes, the freehand curve works best. For straight lines and pieced blocks, try the Polyline Tool. For our Oak Leaf tracing, we will use the Freehand Curve.


To use the Freehand Curve for Tracing

1. Turn off Snap to Grid. This will enable you to freely trace the Oak Leaf.

2. Click on the Freehand Curve Tool . The cursor becomes a cross.

3. Place the cursor where you want to start tracing. Hold down the left mouse button and begin tracing around the Oak Leaf.

4. When you are done, lift up the mouse button.

5. Dont worry if you were not able to trace over the Oak Leaf exactly, we will now learn how to repair a tracing.


Repairing a Tracing Line

No matter how careful you are, you may not get the tracing line exactly right when your drew it.

Now well show you how to repair or adjust the tracing line with the Reshape Tool .

1. Click on the Reshape Tool .

2. Click on the tracing line. Now you will see a series of black boxes. These are called points.

3. To repair the tracing line, click and hold down the left mouse button on a point and drag it so that it covers the tracing image.

4. When you are done adjusting the points, click on the Select Tool to hide the points.


Thats the basics on tracing. In the rest of the chapter, youll learn the finer points of tracing, such as how to add and delete points, adjust the overall smoothness of the freehand curve, convert the tracing into a curve and how to adjust a curve.



Adding and Deleting Points

You can add points to a line to make it smoother. For example, you can add points to a tight curve to make it smoother. Or, you can delete points to make a line straighter. Heres how:

1. Click on the Reshape Tool and then click on the tracing to show the points.

2. Click on the Right mouse Button.

3. Select either Add Points or Delete Points from the menu.

4. To add points, click on the tracing line. Perfect Quilt will add a point.

5. To delete points, click on a point. Perfect Quilt will delete it.

6. When you are done, click the right mouse button again and select Normal Editing Mode from the menu.



Is the Freehand Curve not Smooth Enough?

When you drew with the freehand curve, you actually created a polyline. A Polyline is a line with many points, as you saw when you repaired your tracing. The more points, the smoother the line. But too many points are very difficult to adjust. There are two solutions to this problem. You can adjust the freehand curve to automatically make fewer points, or you can convert the tracing polyline into a curve.


Adjusting the Smoothness the Freehand Curve

1. Click on the File Menu and select Preferences.

2. Click on the Tolerances Tab.

3. On the right side of the tab, you can select Curve Smoothness from the drop-down box. Select best curve for the smoothest possible line. Choose fewest points for a freehand curve line with the fewest possible points.

4. Click the Save Button to keep your setting. Click the OK Button to return to your tracing.


Joining the Tracing Line to Make an Applique Shape

When you are tracing a shape, you will want to be able to paint the shape with fabrics and print templates from it. In order to do this, you will need to join the tracing lines together to make a closed patch. You can close one tracing line or join several tracing lines together. Heres how:

1. Click on the Select Tool.

2. Click on each tracing line that you want to join together. Or, you can draw a box around all the tracing lines to select them.

3. Click on the Effects Menu and select Join. (or press the Control + J keys)

4. Perfect Quilt will join the lines together and paint the new patch with the currently selected fabric or color. You can now print templates of the patch.


Convert the Tracing to a Curve

For maximum smoothness, you can easily convert the tracing into a curve.

1. Click on the Reshape Tool and then click on the tracing to show the points.

2. Click on the Right mouse button. Select Make Curve from the menu.

3. Perfect Quilt will convert the polyline into a series of curves.


Tip: When Perfect Quilt converts a polyline into a curve, it cannot always follow the tracing line exactly, and so you may have to extensively adjust the curves. If you dont like the results, click the right mouse button again and select make polyline to convert the curves back into a polyline.


Adjusting a Curve

If you converted a polyline into a curve, youll want to adjust or fine-tune the curves to more closely match the tracing. Heres how:


1. Click on the Reshape Tool and then click on the tracing to show the points. Instead of all the points on the line, you will see points leading away from the tracing line. These are called Control Points. You move these control points to change the shape of the curve. Most curves combine two or more curve segments. Where these line segments meet is the Anchor Point. You can move the anchor point.

2. Some anchor points have two control points. You can move these two control points together, thus moving both sides of the curve together, or you can move them separately. To move the control points separately, click the right mouse button and click on Bezier Controls Locked so that there is no check box next to it.




Join Curves to make a Closed Shape

You can join curves together just like you did the polyline.

1. Click on the Select Tool

2. Click on each tracing line that you want to join together. Or, you can draw a box around all the tracing lines to select them.

3. Click on the Effects Menu and select Join. (or press the Control + J keys)

4. Perfect Quilt will join the curves together and paint the new patch with the currently selected fabric or color. You can now print templates of the patch.


Hint: You can use the Reshape Tool to reshape the joined patch.


Changing the Color of the Tracing Line

If your image is black and you trace it with a black line, its going to be hard to see the tracing. You can easily change the color of the tracing line for better visibility. Heres how:

1. Click on the Options Menu and then click on Pen/Brush Settings.

2. Click on the Pen Color Button

3. Click on the color you want. You can choose any color in the color palette.

4. Click on the OK Button. When you want to return to a black line, follow steps 1-3 and click on the black color in the color palette.


Saving a Tracing

When you have completed your tracing, you can save the tracing as a Perfect Quilt block.

1. Click on the Save Icon in the Ribbon Bar.

2. Type a name for the block and click on the Save Button. You can save the block into My Library.

3. The original scanned image will not be saved as part of the block.


To Learn More:

You can also use the Polyline Tool to trace. When you trace with the Polyline Tool, you click the

mouse each time you want to change direction. This gives you complete control over the tracing.

To find out more about the Polyline Tool, please consult the Perfect Quilt Assistant.